safe unordered local iterators
Paolo Carlini
paolo.carlini@oracle.com
Wed Jul 20 09:45:00 GMT 2011
On 07/20/2011 10:51 AM, Jonathan Wakely wrote:
> On 20 July 2011 09:38, Jonathan Wakely wrote:
>> See http://gcc.gnu.org/ml/gcc/2011-07/msg00368.html
>>
>> Should code inside namespace __gnu_debug be using std::size_t instead
>> of assuming ::size_t has been declared?
>>
> Or maybe that use (which is the only unqualified size_t I see in
> include/debug/* outside of namespace std) should be using size_type
> anyway.
Indeed. I applied the below, to resolve this pressing issue, Jonathan
will hopefully provide soon feedback about the naming issue.
Paolo.
/////////////////////
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: CL
URL: <http://gcc.gnu.org/pipermail/libstdc++/attachments/20110720/e0e7b040/attachment.ksh>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: patchlet
URL: <http://gcc.gnu.org/pipermail/libstdc++/attachments/20110720/e0e7b040/attachment-0001.ksh>
More information about the Libstdc++
mailing list