templace abuses

François Dumont francois.cppdevs@free.fr
Fri Dec 3 21:20:00 GMT 2010


On 12/03/2010 12:22 PM, Jonathan Wakely wrote:
>
> Hmm, the operators in testsuite_template_abuse.h aren't meant to be
> for iterators though, are they?
> If I understand the problem, it's that greedy operators intended for
> other types interfere and get applied to iterators - so calling them
> iterators_ops is misleading.
>
> How about<testsuite_greedy_ops.h>  ?
>
> Also, namespace N and struct X in that header could be named better -
> short names are ok in a .cc test but a header included from many files
> has more chance of name collisions.  I would suggest maybe namespace
> ops, greedy or greedy_ops.  If the namespace changes then I think X is
> probably OK.
>
> Thanks for fixing this problem, François.
>
> Jonathan
>    
Yes, I like greedy ops. Here is the new proposition.

If so I will apply it as soon as I have been able to test it. I am 
working on an other issue and can't build anymore for the moment.

François
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: ChangeLog.entry
URL: <http://gcc.gnu.org/pipermail/libstdc++/attachments/20101203/4c3a1e28/attachment.ksh>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: greedy_ops.patch
URL: <http://gcc.gnu.org/pipermail/libstdc++/attachments/20101203/4c3a1e28/attachment-0001.ksh>


More information about the Libstdc++ mailing list