Paolo Carlini wrote: > Ok, thanks. Maybe a comment is in order... > > Can you please uglify __inner_product_selector::begin2_iterator? I'm also seeing __inner_product_selector::It2 and, for consistency, O would also say much better __inner_product_selector::_It1 instead of __inner_product_selector::_It. Paolo.