[RFC PATCH, libstdc++]: Fix abi_failure on alpha

Benjamin Kosnik bkoz@redhat.com
Tue Jan 13 18:38:00 GMT 2009


 
> According to abi_check, functions with __float128 arguments should
> have their version set to GLIBCXX_LDBL_3.4.
> 
> This is not the case with numeric_limits:: so abi_check detects
> incompatible symbols.
> 
> Attached patch fixes this problem and fixes abi_check failure on
> alpha.

This is next in my queue to review after 32666. Please do not check
this in.

If you could please open a new bugzilla report just for the alpha abi
check issues, and put in the full verbose log from "make check-abi" I
would appreciate it. (libstdc++.log). Also, please detail how you are
configuring.

thanks,
-benjamin



More information about the Libstdc++ mailing list