[v3] annex D 8 and 9 for C++0x
Gerald Pfeifer
gerald@pfeifer.com
Sun Nov 4 21:06:00 GMT 2007
On Fri, 26 Oct 2007, Benjamin Kosnik wrote:
> I'm willing to concede on this one. There was no compile warning in a
> previous release for this item. Gerald has also asked about this as
> well.
Thanks, Benjamin!
The warning currently is a bit hard to read, since it is based on
specific formatting (as in the source code) but then munged by the
#warning machinery.
For this short snippet
#include <hash_map>
void f() { }
we now get:
In file included from
/usr/nabil-files/pfeifer/gcc/bin/../lib/gcc/i386-unknown-freebsd6.2/4.3.0/../../../../include/c++/4.3.0/backward/hash_map:64,
from x.c:1:
/usr/nabil-files/pfeifer/gcc/bin/../lib/gcc/i386-unknown-freebsd6.2/4.3.0/../../../../include/c++/4.3.0/backward/backward_warning.h:32:2:
warning: #warning This file includes at least one deprecated or antiquated
header. Please consider use of an equivalent, non-deprecated interface for
the requested functionality. A list of valid replacements is as follows:
Use: Instead of: <sstream>, basic_stringbuf <strstream>, strstreambuf
<sstream>, basic_istringstream <strstream>, istrstream <sstream>,
basic_ostringstream <strstream>, ostrstream <sstream>, basic_stringstream
<strstream>, strstream <unordered_set>, unordered_set <ext/hash_set>,
hash_set <unordered_set>, unordered_multiset <ext/hash_set>, hash_multiset
<unordered_map>, unordered_map <ext/hash_set>, hash_map <unordered_map>,
unordered_multimap <ext/hash_set>, hash_multimap <functional>, bind
<functional>, binder1st <functional>, bind <functional>, binder2nd
<functional>, bind <functional>, bind1st <functional>, bind <functional>,
bind2nd <memory>, unique_ptr <memory>, auto_ptr To disable this warning
use -Wno-deprecated.
Gerald
More information about the Libstdc++
mailing list