[v3] ext/type_traits.h

Benjamin Kosnik bkoz@redhat.com
Mon Sep 25 08:23:00 GMT 2006


> I want to say that whereas, per your citation, I also called the trait 
> to_* when I "invented" ;) it, the new naming scheme may have advantages: 
> we are directing attention to the syntactic notion of adding the 
> ""unsigned qualification"" or removing it, not to the actual signedness 
> of the types at issue in input and output (I hope I'm sufficiently 
> clear).

I think so. FYI this is the reason I think __add_unsigned is better than __add_signed.

-benjamin



More information about the Libstdc++ mailing list