Fri Sep 15 14:34:00 GMT 2006
Paolo Carlini wrote:
> Peter Doerfler wrote:
>> I think it makes sense to move these out as well. Even if they are only
>> used in random ATM that seems to be a general concept that could be
>> useful elsewhere. Following the lead of tr1::type_traits the name
>> "add_unsigned" might be better, and the corresponding "remove_unsigned"
>> could be added as well.
> As the author of those traits - which, so far, do not appear in any
> standard document, for better or worse ;) - I kindly request that they
> keep a single or double underscore in front, as the rest of
> tr1/random, the only place where they are currently used.
Ah, yes, I also used a restricted version of the same traits in locale
(locale_facets.tcc), and commonizing that code too would be great...
provided we make sure not injecting non-uglified names in a standard
More information about the Libstdc++