GTHREAD_MUTEX_INIT

Loren James Rittle rittle@latour.rsch.comm.mot.com
Tue Mar 2 12:21:00 GMT 2004


> I upgraded from gcc 2.95 to gcc 3.2 the other day. [...]
> The upgrade went ok.  But now I'm trying to compile something and I get the 
> following error message:
> /usr/local/include/c++/3.2/bits/stl_threads.h:79:2: #error 
> __GTHREAD_MUTEX_INIT or __GTHREAD_MUTEX_INIT_FUNCTION should be defined by 
> gthr.h abstraction
> layer, report problem to libstdc++@gcc.gnu.org.

Thank you for the report.  That should not be happening.  However, it
is possible that bug exists on some platforms, in that release of gcc.
Unfortunately, no one (to my knowledge) is fixing bugs ("for free") in
gcc 3.2 anymore.  If you install gcc 3.3.3 and see the bug, then I
will gladly fix it.

Regards,
Loren



More information about the Libstdc++ mailing list