readelf_need_wide
Loren James Rittle
rittle@latour.rsch.comm.mot.com
Thu Sep 5 16:31:00 GMT 2002
Phil writes:
>>> The command's normal exit value has to be extracted with WEXITSTATUS.
>> Yikes! Using this macro would appear to be *far* less portable IMHO!
> Well, it's POSIX. And SUSv2. (But probably not BSD.)
No, BSD has the macro in question in an obscure system header. ;-)
However, we called system() not some form of wait() thus I'm skeptical
that WEXITSTATUS may be used portability. Does POSIX document that
system() must be implemented to preserve such status?
> The more I play with abi_check.cc, the more I become convinced that we'll
> shortly be renaming it to abi_check.cc.in, and replacing these run-time
> tests with autoconf'd macros.
Seems that the entire shell call-out could be moved to the Makefile
rule and then pass multiple files as input to the actual abi_check
process. Any C++ program with a call to system() is ripe for change. ;-)
Regards,
Loren
More information about the Libstdc++
mailing list