protected non-uglified member functions
Phil Edwards
phil@jaj.com
Tue May 28 12:47:00 GMT 2002
On Tue, May 28, 2002 at 08:58:37AM -0400, Stephen M.Webb wrote:
> I suspect they're an artifact of prestandard implementation.
You're probably correct.
> Many of the containers and algorithms have similar specializations
> dispatched from the public nonuglified interface. It might be a good
> idea to come up with a consistent naming convention to make
> understanding the code a little easier in the future. I mean, since
> you're renaming them anyways.
Yeah, between renaming and reordering and recommenting, I think that
every function in stl_deque.h is at least briefly documented now, unless
I missed something. I'm going back and doing that same for stl_vector.h
now for consistency before I check them both in.
> The confusing morass of std::copy is an example of how not
> to name your helper functions.
No argument from me there...
Phil
--
If ye love wealth greater than liberty, the tranquility of servitude greater
than the animating contest for freedom, go home and leave us in peace. We seek
not your counsel, nor your arms. Crouch down and lick the hand that feeds you;
and may posterity forget that ye were our countrymen. - Samuel Adams
More information about the Libstdc++
mailing list