auto_ptr problems

B. Kosnik
Wed Jul 3 13:34:00 GMT 2002

> > I agree that the expected failure tests should be lumped in with the
> > 
> > expected pass tests.  I'd suggest appending rather than prepending
> > the "fail" or whatever bit to the name so it sorts nicely.  It's a
> > small thing but the small things add up.
> Good point.

Ok, agreed. Keeping a sane directory structure is a good thing.

> > I'd also point out that unlike the expected pass tests, a separate
> > test source file is required for each expected compilation failure. 
> > You'd end up with
> > 
> >     nn_foo/
> >     nn_foo/
> >     nn_foo/
> >     nn_foo/
> > 
> > and so forth.

Not necessarily. You can test for multiple compilation fails per file, I
believe, with dejagnu.

If you can't, I think your proposed naming scheme makes sense.

Thanks for the suggestions. I hope to have this in today.


More information about the Libstdc++ mailing list