problem getting std::string::_Rep::_S_max_size and std::string::_ Rep::_S_terminal under AIX linked

Freimann Mario mario.freimann@siemens.com
Wed Jan 30 05:02:00 GMT 2002


hello,

i'm working on this problem for days now. i don't get it solved :-( please
help me ...

i want to compile a program under AIX 4.3.3. the program uses some
encryption features. therefore i used the crypto++ 4.x library. i only need
8 files of this, 2 of them are useing std::string really intensive. these
files are causing the linking errors.

the compiler i want to use is gcc. therefore i searched for a binary version
of the gcc, as i used to use gcc on other os (solaris, hp-ux, linux), too.
on the other systems no problem occured (i think they use 2.95 or so). 
for AIX i only found a version 3.0.1. i asked the admin to install it. he
did it for me.

compiling the program worked fine. but when the thing got to linking
problems occured. the two symbols std::string::_Rep::_S_max_size and
std::string::_Rep::_S_terminal couldn't be ressolved. so i looked in google
groups what was wrong. i found out that it is a problem in the
libstdc++-library used in gcc 3.0.1. so i downloaded the gcc 3.0.3 from the
gnu-server and wanted only to rebuild the libstdc++-v3 (make
all-target-libstdc++-v3). this took about 7 hourse and ended in an error i
couldn't figure out. i think it happend at the test parts, as i found a new
stdlibc++-library (~ 3,7mb). using this new library didn't solve my
problems. the two symbols are still unresolved. using nm on the new lib
(libstdc++.a in the .libs directory) i didn't found the symbols.

next thing i did was looking in the mailing list archive of gnu. i found
several threads, but i didn't realize the solution for the problem.

i don't know what else to do. could someboldy please help me?

mario freimann



More information about the Libstdc++ mailing list