[v3] remove non-standard basic_filebuf members, fd, FILE filebufs

Benjamin Kosnik bkoz@redhat.com
Tue Apr 30 00:59:00 GMT 2002


> c_filebuf, then? I'll add a ctor that sets file permissions as well.
> I think those were the top three gripes then.

Ok, I was wrong: c_locale, c_file are used elsewhere to indicate
underlying "C" types. If anything, cfile would be better. All the
proposed variations of c + file + filebuf names kind of suck though.

I'm inclined to just keep two separate files, and the names as posted. 

The concept_checking bit is definitely in though.

I'll wait another little bit before checking this in, but it seems as if
the idea is good.

-benjamin



More information about the Libstdc++ mailing list