[v3] remove non-standard basic_filebuf members, fd, FILE filebufs

Gabriel Dos Reis gdr@codesourcery.com
Mon Apr 29 18:06:00 GMT 2002


Phil Edwards <phil@jaj.com> writes:

[...]

| > +   template<typename _CharT, typename _Traits = std::char_traits<_CharT> >
| > +     class file_filebuf : public std::basic_filebuf<_CharT, _Traits>
| 
| How about naming this class cfile_filebuf instead?  This highlights the
| point of FILE* compatability, and follows the <c*> header naming convention.

But then it is not a header inherited from C.

The convention is that a header inherited from C, when C++ malassed,
becomes a <cxxx> thing.

I would suggest we do not confuse the situation.

-- Gaby



More information about the Libstdc++ mailing list