Can't build 2.90.8 with gcc 2.95.2

Nathan Myers ncm@nospam.cantrip.org
Tue Mar 13 18:21:00 GMT 2001


On Tue, Mar 13, 2001 at 08:10:12PM -0500, Phil Edwards wrote:
> On Tue, Mar 13, 2001 at 05:39:40PM -0600, Kevin S. Van Horn wrote:
> > I'm trying to build gcc 2.95.2 and libstdc++-2.90.8 together from scratch.
> > It dies in the middle of building libstdc++ with the following errors
> > complaining about not being able to inline a function call.  I'm using a
> > stock RedHat Linux 6.2 system, with glibc 2.1.3.
> 
> In the docs directory of the 2.90.8 sources are configuration and
> installation instructions in HTML.  The one you want is (I think)
> install.html.  There are notes in there regarding this problem and others
> that occasionally would occur in the .8 snapshot.

I don't find anything about this in docs/ in 2.90.8.  

I had to change a line in src/Makefile.in:

- WERROR = -Werror
+ WERROR =

Maybe this should be on the FAQ.

Nathan Myers
ncm at cantrip dot org



More information about the Libstdc++ mailing list