libstdc++-v3 Does Not Compile

Phil Edwards pedwards@disaster.jaj.com
Fri Mar 9 09:28:00 GMT 2001


On Fri, Mar 09, 2001 at 11:06:49AM -0500, Mohamed Ezz wrote:
> I decided to download the sources for libstc++-v3 and gcc-2.95.2 and
> recompile everything. I use the following commands for the
> configuration:

The 2.95.2 compiler cannot be used with any libstdc++-v3 sources more
recent than the 2.90.8 snapshot.  Please see

    http://gcc.gnu.org/libstdc++/status.html

for more information.  If you must use 2.95.2, you'll need to use that
snapshot.

If you can use a more recent compiler, you could (for example) build a
GCC 3.0 prerelease snapshot which will include libstdc++-v3 by default.
That will give you an idea of what the 3.0 official release will look like.


Phil

-- 
pedwards at disaster dot jaj dot com  |  pme at sources dot redhat dot com
devphil at several other less interesting addresses in various dot domains
The gods do not protect fools.  Fools are protected by more capable fools.



More information about the Libstdc++ mailing list