> you might want to just re-name to __out_bufsize and __in_bufsize. Agreed. >> + #if _GLIBCPP_AVOID_FSEEK >> + __in_bufsize = 1; >> + #endif >> + > should probably add a comment as to why this is the case Agreed. I will bootstrap those changes and apply. Regards, Loren