2.95.3.test3 breaks code that worked with 2.95.2?

Frédéric L. W. Meunier 0@pervalidus.net
Sat Feb 17 13:32:00 GMT 2001


Hi. I know nothing about c++ and libstdc++, but noticed that
trying to build the same application that used to build with
2.95.2 (I was using glibc 2.1.3 and binutils 2.10.0.24 from
Slackware) doesn't anymore with 2.95.3.test3.

Today I built gcc 2.95.3.test3, binutils 2.10.91.0.2, and
glibc 2.2.2, in this order.

Then I tried to build wvdial 1.41-10 from RedHat 7.0, and got
the following error:

--> Making all in /usr/local/src/wvdial-1.41/streams...
Using my own device locking functions in wvlockfile.
g++   -Wall -D_BSD_SOURCE -D_GNU_SOURCE -O -DDEBUG=0 -DNDEBUG -I.. -I../utils -MMD -c wvstream.cc
wvstream.cc: In method `void WvStream::flush(long int)':
wvstream.cc:305: implicit declaration of function `int time(...)'
make[1]: *** [wvstream.o] Error 1
make: *** [subdirs] Error 2

Line 305:

        time_t now = time(NULL);

Any hints?

-- 
Frédéric L. W. Meunier - http://www.pervalidus.net/
0@pervalidus.{net, {dyndns.}org} Tel: 55-21-717-2399 (Niterói-RJ BR)



More information about the Libstdc++ mailing list