[PATCH] For SGI stl_algo.h extensions (was: Re: [RFC] Moving apart SGI extensions)

Gabriel Dos Reis gdr@codesourcery.com
Fri Dec 28 02:37:00 GMT 2001


Phil Edwards <pedwards@disaster.jaj.com> writes:

| On Thu, Dec 27, 2001 at 12:16:20PM +0100, Paolo Carlini wrote:
| > Comments? A better name than algorithm_ext.h ?
| 
| I like algorithm.h myself, but no big deal.
| 
| 
| > +namespace __gnu_cxx
| > +{
| [...]
| > +     typename std::iterator_traits<_InputIter>::value_type >)
| 
| Here's a question from a discussion we're having where I am:  should
| this be ::std::iterator_traits instead, or is the code legit as stands?

The code is correct as is.

-- Gaby
CodeSourcery, LLC                       http://www.codesourcery.com



More information about the Libstdc++ mailing list