[PATCH] For SGI stl_algo.h extensions (was: Re: [RFC] Moving apart SGI extensions)
Paolo Carlini
pcarlini@unitus.it
Thu Dec 27 05:51:00 GMT 2001
[Sorry. This is my *first* reply: forgot to CC the list]
Phil Edwards wrote:
> On Thu, Dec 27, 2001 at 12:16:20PM +0100, Paolo Carlini wrote:
> > Comments? A better name than algorithm_ext.h ?
>
> I like algorithm.h myself, but no big deal.
Hummm. I'm about to submit for review a new version of the patch choosing
algorithm. My preference is motivated by the others header files meant to be
included by the user already present in include/ext and, more generally, by the
fact that generally, in C++ *all* the header files do not have the .h extension.
> +namespace __gnu_cxx
> > +{
> [...]
> > + typename std::iterator_traits<_InputIter>::value_type >)
>
> Here's a question from a discussion we're having where I am: should
> this be ::std::iterator_traits instead, or is the code legit as stands?
> (I know it passes the testsuite and all, but a few people here feel that's
> a compiler problem.)
>
> That wasn't a very clear question, but I'm having a hard time explaining
> the problem. :-)
I don't know sufficiently well this technical detail to meaningfully comment on
this. Again, the patch I'm about to submit will have simply std::, not ::std:: My
feeling, however is that you are right, in that, conceptually, in order to get to
stuff inside std:: from __gnu_cxx first you have to exit from __gnu_cxx, then
enter inside std::
Right?
Anyway, this is very easy to change...
Gaby?
Cheers,
Paolo.
More information about the Libstdc++
mailing list