[PATCH] For SGI stl_algo.h extensions (was: Re: [RFC] Moving apart SGI extensions)

Phil Edwards pedwards@disaster.jaj.com
Thu Dec 27 05:24:00 GMT 2001


On Thu, Dec 27, 2001 at 12:16:20PM +0100, Paolo Carlini wrote:
> Comments? A better name than algorithm_ext.h ?

I like algorithm.h myself, but no big deal.


> +namespace __gnu_cxx
> +{
[...]
> +     typename std::iterator_traits<_InputIter>::value_type >)

Here's a question from a discussion we're having where I am:  should
this be ::std::iterator_traits instead, or is the code legit as stands?
(I know it passes the testsuite and all, but a few people here feel that's
a compiler problem.)

That wasn't a very clear question, but I'm having a hard time explaining
the problem.  :-)


Phil

-- 
If ye love wealth greater than liberty, the tranquility of servitude greater
than the animating contest for freedom, go home and leave us in peace.  We seek
not your counsel, nor your arms.  Crouch down and lick the hand that feeds you;
and may posterity forget that ye were our countrymen.            - Samuel Adams



More information about the Libstdc++ mailing list