[PATCH] For SGI stl_algo.h extensions (was: Re: [RFC] Moving apart SGI extensions)

Gabriel Dos Reis gdr@codesourcery.com
Thu Dec 27 03:24:00 GMT 2001


Paolo Carlini <pcarlini@unitus.it> writes:

| Ok, since we all more or less agree that the approach suggested by Benjamin is the
| right one, I have prepared this patch.
| 
| It eviscerates SGI extensions from stl_algo.h, put them in a separate file
| (ext/algorithm_ext.h), inside namespace __gnu_cxx, not mangled, including
| std_algorithm.h in order to have available all the bits necessary for the
| implementation.
| 
| Comments? A better name than algorithm_ext.h ?

Why not just call it algorithm.h, or algorithm?  After all, it is in
the separate directory.

Apart from that, the patch looks OK for me although I don't know
whether he copyright notice is correct or not.

-- Gaby
CodeSourcery, LLC                       http://www.codesourcery.com



More information about the Libstdc++ mailing list