[RFC] Moving apart SGI extensions
Gabriel Dos Reis
gdr@codesourcery.com
Thu Dec 27 03:09:00 GMT 2001
Paolo Carlini <pcarlini@unitus.it> writes:
[...]
| Honestly, for stuff like those bits in stl_algo.h I find it somewhat unnatural:
| conceptually they are part of <algorithm> and depends on all the headers
| specified in std_algorithm.h. So, if the user is supposed to include the
| ext-header and use it we should duplicate most of the structure of
| <algorithm>-std_algorithm.h only for those extra bits.
Hmm, I don't favor code duplication. Sooner or later they will get out
of sync. Normally, the <ext/xxx> headers would include the standard
headers and add the additional bits they want to. Or do I misunderstand?
| ... on the other hand, the important advantage is that the names would be not
| mangled, so the user would simply add at the beginning of the legacy code an
| additional include and an using namespace __gnu_cxx ... What do you think Gaby?
I favour that approach.
| PS. I have a couple of partially-reviewed/unapproved patches...
| 1- Some more missing typename keywords in preparation for the new parser (quite
| harmless, IMHO):
|
| http://gcc.gnu.org/ml/libstdc++/2001-12/msg00332.html
|
| (as soon as Nathan Sidwell refines his deprecated implicit typename warning I
| will separately simplify a typedef in stl_rope.h)
This lokks OK for me.
-- Gaby
CodeSourcery, LLC http://www.codesourcery.com
More information about the Libstdc++
mailing list