[RFA:] libstdc++-v3 patches to bootstrap on gnulibc1 andglibc 2.0

Ulrich Drepper drepper@redhat.com
Tue Nov 21 19:45:00 GMT 2000


Hans-Peter Nilsson <hp@bitrange.com> writes:

> Right, I could have been clearer and shouldn't have generalized.  There
> was declaration mismatch in that the system definition for __P in libc
> 5.3.12 and glibc 2.0 lacked __THROW and so the declarations for
> __underflow and __overflow which for some reason were in
> /usr/include/stdio.h for both versions were then naked and throw-less,
> mismatching the V3/libio.h ones.  Producing this compile-error:

You mean you are using the /usr/include/stdio.h and libio.h files on
libc5 and glibc 2.0 systems?  You cannot do this.  In fact, only with
glibc 2.2 is it safe to use the system headers and the libio in the
libc.

-- 
---------------.                          ,-.   1325 Chesapeake Terrace
Ulrich Drepper  \    ,-------------------'   \  Sunnyvale, CA 94089 USA
Red Hat          `--' drepper at redhat.com   `------------------------


More information about the Libstdc++ mailing list