Libstdc++ 2.90.6

Juergen Heinzl juergen@monocerus.demon.co.uk
Sun Aug 8 14:19:00 GMT 1999


Hello,

>     I just tried building your latest build (libstdc++ 2.90.6) on an
> i686-pc-linux-gnu with gcc2.95. I successfully did a make, but in the
> make install I get the following:
> [dara@ce275007 libstdc++-2.90.6]$ make install
> Making install in math
> make[1]: Entering directory `/home/dara/libstdc++-2.90.6/math'
> make[2]: Entering directory `/home/dara/libstdc++-2.90.6/math'
> make[2]: Nothing to be done for `install-exec-am'.
[...]
> make[2]: Nothing to be done for `install-data-am'.
> make[2]: Leaving directory `/home/dara/libstdc++-2.90.6/src'
> make[1]: *** No rule to make target `bits/basic_ios.h', needed by
> `/usr/local//i nclude/g++-v3/bits/basic_ios.h'.  Stop.
> make[1]: Leaving directory `/home/dara/libstdc++-2.90.6/src'
> make: *** [install-recursive] Error 1
> [dara@ce275007 libstdc++-2.90.6]$ cd ..
> [dara@ce275007 dara]$
[...]

I'd the same problem, make version is GNU make 3.77. Digging a very
little bit, my solution was more a sledge hammer approach, I think
the one to blame is the missing VPATH statement, which is part of
/src/Makefile.in but does not make it into the final one.

> Can somebody explain to me what I'm doing wrong? I'm a little nervous
I tried ... maybe lightyears off as usual 8-)

Ta',
Juergen

-- 
\ Real name     : Jürgen Heinzl                 \       no flames      /
 \ EMail Private : juergen@monocerus.demon.co.uk \ send money instead /


More information about the Libstdc++ mailing list