[gcc r16-8471] Daily bump.
GCC Administrator
gccadmin@gcc.gnu.org
Sun Apr 5 00:16:53 GMT 2026
https://gcc.gnu.org/g:a34b142411d129828cc8e1c9a9f7b77072ee1f5f
commit r16-8471-ga34b142411d129828cc8e1c9a9f7b77072ee1f5f
Author: GCC Administrator <gccadmin@gcc.gnu.org>
Date: Sun Apr 5 00:16:26 2026 +0000
Daily bump.
Diff:
---
gcc/ChangeLog | 70 +++++++++++++++++++++++++++++++++++++++++++++++++
gcc/DATESTAMP | 2 +-
gcc/cp/ChangeLog | 29 ++++++++++++++++++++
gcc/fortran/ChangeLog | 7 +++++
gcc/testsuite/ChangeLog | 35 +++++++++++++++++++++++++
libgfortran/ChangeLog | 6 +++++
libstdc++-v3/ChangeLog | 11 ++++++++
7 files changed, 159 insertions(+), 1 deletion(-)
diff --git a/gcc/ChangeLog b/gcc/ChangeLog
index 376f95759e6b..ada6c2359cfa 100644
--- a/gcc/ChangeLog
+++ b/gcc/ChangeLog
@@ -1,3 +1,73 @@
+2026-04-04 Sandra Loosemore <sloosemore@baylibre.com>
+
+ * doc/invoke.texi (Picolibc Options): Copy-edit for markup, use
+ of proper names, etc.
+
+2026-04-04 Sandra Loosemore <sloosemore@baylibre.com>
+
+ * doc/invoke.texi (GCC Command Options): Move Picolibc Options
+ section to Target-Specific Options.
+ (Option Summary): Likewise.
+
+2026-04-04 Sandra Loosemore <sloosemore@baylibre.com>
+
+ * doc/extend.texi (Common Attributes): Fix cross-reference for
+ renamed "Submodel Options" -> "Target-Specific Options".
+ * doc/invoke.texi (Invoking GCC): Likewise for the menu.
+ (Option Summary): Likewise for the use here.
+ (Submodel Options): Rename to Target-Specific Options. Leave
+ an anchor with the old name. Add better index entries. Rewrite
+ introductory text.
+ (Precompiled Headers): Fix another cross-reference.
+
+2026-04-04 Sandra Loosemore <sloosemore@baylibre.com>
+
+ PR target/107337
+ * doc/invoke.texi (x86 Options): Add CX16 feature to nocona,
+ alderlake, arrowlake, arrowlake-s, pantherlake, novalake,
+ bonnell, sierraforest, grandridge, clearwaterforest, and amdfam10
+ family processors.
+
+2026-04-04 Richard Biener <rguenther@suse.de>
+
+ * doc/gccint.texi: Add named pattern index with @mdindex.
+ * doc/md.texi (Standard Pattern Names For Generation): Split
+ table into two using subsections, splitting out vectorizer
+ related standard patterns. Use @mdindex for all standard
+ pattern names.
+
+2026-04-04 Takayuki 'January June' Suwa <jjsuwa_sys3175@yahoo.co.jp>
+
+ * config/xtensa/xtensa.cc (xtensa_legitimize_address):
+ Add code to legitimize the displacement of 64 kilobytes before and
+ after using two ADDMI instructions.
+
+2026-04-04 Takayuki 'January June' Suwa <jjsuwa_sys3175@yahoo.co.jp>
+
+ * config/xtensa/xtensa.md (negsf2):
+ Change define_insn to define_insn_and_split, and replace the
+ corresponding output template with the split pattern.
+
+2026-04-04 Takayuki 'January June' Suwa <jjsuwa_sys3175@yahoo.co.jp>
+
+ * config/xtensa/xtensa.cc (TARGET_DIFFERENT_ADDR_DISPLACEMENT_P):
+ Remove.
+
+2026-04-04 Takayuki 'January June' Suwa <jjsuwa_sys3175@yahoo.co.jp>
+
+ * config/xtensa/xtensa.cc (smalloffset_mem_p):
+ Rename it to smalloffset_address_p and remove the result check
+ of MEM_P().
+ (constantpool_address_p): Change from static scope to global.
+ * config/xtensa/xtensa-protos.h (smalloffset_mem_p):
+ Rename it to smalloffset_address_p.
+ (constantpool_address_p): New function prototype.
+ * config/xtensa/constraints.md (R):
+ Change the call in (match_test "...") from smalloffset_mem_p()
+ to smalloffset_address_p().
+ (T, U): Change the call in (match_test "...") from
+ constantpool_mem_p() to constantpool_address_p().
+
2026-04-03 Sandra Loosemore <sloosemore@baylibre.com>
PR c/123234
diff --git a/gcc/DATESTAMP b/gcc/DATESTAMP
index 05c465eb48c8..74f24011f1ba 100644
--- a/gcc/DATESTAMP
+++ b/gcc/DATESTAMP
@@ -1 +1 @@
-20260404
+20260405
diff --git a/gcc/cp/ChangeLog b/gcc/cp/ChangeLog
index dd4d9fe2425e..27df3beae173 100644
--- a/gcc/cp/ChangeLog
+++ b/gcc/cp/ChangeLog
@@ -1,3 +1,32 @@
+2026-04-04 Roger Sayle <roger@nextmovesoftware.com>
+
+ PR c++/124573
+ * decl.cc (finish_enum_value_list): Defend against a DECL_INITIAL
+ being NULL during error recovery.
+
+2026-04-04 Jakub Jelinek <jakub@redhat.com>
+
+ * parser.cc (cp_parser_expansion_statement): Temporarily set
+ in_expansion_stmt to true around cp_parser_simple_declaration
+ for range_decl.
+ (cp_parser_decomposition_declaration): Don't reject structured binding
+ packs if in_expansion_stmt is set.
+
+2026-04-04 Jakub Jelinek <jakub@redhat.com>
+
+ PR c++/124487
+ * mangle.cc (write_type) <case PACK_INDEX_TYPE>: Handle pack index
+ mangling unless (for now) PACK_INDEX_PACK is a TREE_VEC.
+ (write_expression): Handle PACK_INDEX_EXPR.
+
+2026-04-04 Jakub Jelinek <jakub@redhat.com>
+
+ PR c++/124198
+ * parser.cc (cp_parser_pack_index): If index is not type dependent,
+ call build_converted_constant_expr on it. Return error_mark_node
+ if index is error_operand_p.
+ * pt.cc (tsubst_pack_index): Likewise.
+
2026-04-03 Alexandre Oliva <oliva@adacore.com>
* coroutines.cc (cp_coroutine_transform::build_ramp_function):
diff --git a/gcc/fortran/ChangeLog b/gcc/fortran/ChangeLog
index dd7bec4a0e51..4055003b0b35 100644
--- a/gcc/fortran/ChangeLog
+++ b/gcc/fortran/ChangeLog
@@ -1,3 +1,10 @@
+2026-04-04 Harald Anlauf <anlauf@gmx.de>
+
+ PR fortran/66973
+ * interface.cc (gfc_compare_actual_formal): Check that C_LOC and
+ C_FUNLOC from ISO_C_BINDING as actual argument are passed to a
+ dummy argument of matching type C_PTR/C_FUNPTR.
+
2026-04-03 Harald Anlauf <anlauf@gmx.de>
PR fortran/124652
diff --git a/gcc/testsuite/ChangeLog b/gcc/testsuite/ChangeLog
index 6dcec995d3d9..c8191f12885a 100644
--- a/gcc/testsuite/ChangeLog
+++ b/gcc/testsuite/ChangeLog
@@ -1,3 +1,38 @@
+2026-04-04 Roger Sayle <roger@nextmovesoftware.com>
+
+ PR c++/124573
+ * g++.dg/other/enum4.C: New test case.
+
+2026-04-04 Jakub Jelinek <jakub@redhat.com>
+
+ * g++.dg/cpp26/expansion-stmt34.C: New test.
+
+2026-04-04 Jakub Jelinek <jakub@redhat.com>
+
+ PR c++/124487
+ * g++.dg/cpp26/pack-indexing7.C: Don't xfail dg-bogus.
+ * g++.dg/cpp26/pack-indexing22.C: New test.
+
+2026-04-04 Jakub Jelinek <jakub@redhat.com>
+
+ PR c++/124198
+ * g++.dg/cpp26/pack-indexing2.C (getT2, badtype4): Expect different
+ diagnostics.
+ * g++.dg/cpp26/pack-indexing20.C: New test.
+ * g++.dg/cpp26/pack-indexing21.C: New test.
+
+2026-04-04 Harald Anlauf <anlauf@gmx.de>
+
+ PR fortran/66973
+ * gfortran.dg/generic_36-1.f90: New test.
+ * gfortran.dg/generic_36-2.f90: New test.
+
+2026-04-04 Jerry DeLisle <jvdelisle@gcc.gnu.org>
+
+ PR libfortran/124543
+ * gfortran.dg/pr124543.f90: Set result to 'UNDEFINED' in two
+ places.
+
2026-04-03 H.J. Lu <hjl.tools@gmail.com>
PR target/123210
diff --git a/libgfortran/ChangeLog b/libgfortran/ChangeLog
index a7040ff739d4..2174474fd120 100644
--- a/libgfortran/ChangeLog
+++ b/libgfortran/ChangeLog
@@ -1,3 +1,9 @@
+2026-04-04 Jerry DeLisle <jvdelisle@gcc.gnu.org>
+
+ PR libfortran/124543
+ * io/inquire.c (inquire_via_unit): Adjust the logic to
+ treat formatted vs unformatted correctly.
+
2026-03-30 Jerry DeLisle <jvdelisle@gcc.gnu.org>
PR libfortran/124543
diff --git a/libstdc++-v3/ChangeLog b/libstdc++-v3/ChangeLog
index 96cad9a88eac..d3a407872a27 100644
--- a/libstdc++-v3/ChangeLog
+++ b/libstdc++-v3/ChangeLog
@@ -1,3 +1,14 @@
+2026-04-04 Matthias Kretz <m.kretz@gsi.de>
+
+ PR libstdc++/124722
+ * testsuite/std/simd/traits_impl.cc: Add __STDCPP_FLOAT16_T__
+ and __STDCPP_BFLOAT16_T__ guards.
+
+2026-04-04 Tomasz Kamiński <tkaminsk@redhat.com>
+
+ * testsuite/20_util/optional/ref/access.cc: Provide
+ definition for foo().
+
2026-04-03 Jakub Jelinek <jakub@redhat.com>
* include/bits/version.def (is_structural): New.
More information about the Libstdc++-cvs
mailing list