[gcc r16-3756] Daily bump.

GCC Administrator gccadmin@gcc.gnu.org
Thu Sep 11 00:20:41 GMT 2025


https://gcc.gnu.org/g:e24a539367d439f3b62c91fd10f5ddfb350fc7ab

commit r16-3756-ge24a539367d439f3b62c91fd10f5ddfb350fc7ab
Author: GCC Administrator <gccadmin@gcc.gnu.org>
Date:   Thu Sep 11 00:20:14 2025 +0000

    Daily bump.

Diff:
---
 contrib/ChangeLog       |  5 ++++
 gcc/ChangeLog           | 60 ++++++++++++++++++++++++++++++++++++++
 gcc/DATESTAMP           |  2 +-
 gcc/ada/ChangeLog       | 16 +++++++++++
 gcc/c/ChangeLog         | 16 +++++++++++
 gcc/cp/ChangeLog        | 11 +++++++
 gcc/testsuite/ChangeLog | 76 +++++++++++++++++++++++++++++++++++++++++++++++++
 libstdc++-v3/ChangeLog  | 53 ++++++++++++++++++++++++++++++++++
 8 files changed, 238 insertions(+), 1 deletion(-)

diff --git a/contrib/ChangeLog b/contrib/ChangeLog
index ab38d8bd5273..454ac9ba0582 100644
--- a/contrib/ChangeLog
+++ b/contrib/ChangeLog
@@ -1,3 +1,8 @@
+2025-09-10  Christophe Lyon  <christophe.lyon@linaro.org>
+
+	* compare_tests: Improve non-unique tests report when testing
+	several configurations.
+
 2025-09-08  Christophe Lyon  <christophe.lyon@linaro.org>
 
 	* compare_tests: Report non-unique test names.
diff --git a/gcc/ChangeLog b/gcc/ChangeLog
index 2a445e7352b1..ffe69b64348a 100644
--- a/gcc/ChangeLog
+++ b/gcc/ChangeLog
@@ -1,3 +1,63 @@
+2025-09-10  Georg-Johann Lay  <avr@gjlay.de>
+
+	PR target/81540
+	PR target/49857
+	* common/config/avr/avr-common.cc: Disable -ftree-switch-conversion.
+
+2025-09-10  Takayuki 'January June' Suwa  <jjsuwa_sys3175@yahoo.co.jp>
+
+	* config/xtensa/xtensa.h (TARGET_SMALL_REGISTER_CLASSES_FOR_MODE_P):
+	Change "Xtrnase" in the comment to "Xtensa".
+
+2025-09-10  Peter Bergner  <bergner@tenstorrent.com>
+
+	PR target/121878
+	* config/riscv/tt-ascalon-d8.md (tt_ascalon_d8_vec_idiv_half): Test the
+	Selected Element Width (SEW) rather than the mode.
+	(tt_ascalon_d8_vec_idiv_single): Likewise.
+	(tt_ascalon_d8_vec_idiv_double): Likewise.
+	(tt_ascalon_d8_vec_float_divsqrt_half): Likewise.
+	(tt_ascalon_d8_vec_float_divsqrt_single): Likewise.
+	(tt_ascalon_d8_vec_float_divsqrt_double): Likewise.
+
+2025-09-10  Juergen Christ  <jchrist@linux.ibm.com>
+
+	* tree-vect-loop.cc (vectorizable_live_operation_1): Fix
+	load/store bias handling.
+
+2025-09-10  Paul-Antoine Arras  <parras@baylibre.com>
+
+	* config/riscv/autovec-opt.md (*vfwsub_wf_<mode>): New pattern to
+	combine float_extend + vec_duplicate + vfsub.vv into vfwsub.wf.
+
+2025-09-10  Jakub Jelinek  <jakub@redhat.com>
+
+	PR middle-end/121828
+	* gimple-lower-bitint.cc (gimple_lower_bitint): For REALPART_EXPR
+	consumed by store in the same bb and with REALPART_EXPR from
+	optimizable_arith_overflow, don't add REALPART_EXPR lhs to
+	the m_names bitmap only if the cast from IMAGPART_EXPR doesn't
+	appear in between the REALPART_EXPR and the store.
+
+2025-09-10  Jakub Jelinek  <jakub@redhat.com>
+
+	PR middle-end/121831
+	* expr.cc (raw_data_cst_read_str): New function.
+	(store_constructor) <case ARRAY_TYPE>: Handle RAW_DATA_CST.
+
+2025-09-10  Juergen Christ  <jchrist@linux.ibm.com>
+
+	* config/s390/s390.h (CLZ_DEFINED_VALUE_AT_ZERO): Adjust and
+	return 2.
+	(CTZ_DEFINED_VALUE_AT_ZERO): Return 2.
+	* config/s390/s390.md (clzsi2): Implement.
+	(ctzsi2): Implement.
+
+2025-09-10  Maximilian Immanuel Brandtner  <maxbr@linux.ibm.com>
+
+	* config/s390/vector.md (*vec_extract<mode>_plus_zero_extend):
+	Fix define insn.
+
 2025-09-09  Andrew Stubbs  <ams@baylibre.com>
 
 	* config/gcn/gcn-devices.def: Correct the Max ISA VGPRs counts for
diff --git a/gcc/DATESTAMP b/gcc/DATESTAMP
index 240fc076c6a7..cc3bc45669de 100644
--- a/gcc/DATESTAMP
+++ b/gcc/DATESTAMP
@@ -1 +1 @@
-20250910
+20250911
diff --git a/gcc/ada/ChangeLog b/gcc/ada/ChangeLog
index d80538b30cd2..e6eecc1ea474 100644
--- a/gcc/ada/ChangeLog
+++ b/gcc/ada/ChangeLog
@@ -1,3 +1,19 @@
+2025-09-10  Eric Botcazou  <ebotcazou@adacore.com>
+
+	PR ada/121885
+	* snames.ads-tmpl (Pragma_Id): Rename Unknown_Pragma to
+	Pragma_Unknown for the sake of XSnamesT.
+	* snames.adb-tmpl (Get_Pragma_Id): Adjust to above renaming.
+	* snames.h-tmpl (Attribute_Id): Change underlying type to Byte.
+	(Get_Attribute_Id): Use Byte as return value.
+	(Pragma_Id): Change underlying type to Word.
+	(Get_Pragma_Id): Use Word as return value.
+	* types.h (Word): New typedef.
+	* exp_prag.adb (Expand_N_Pragma): Remove useless comment.
+	* par-prag.adb (Prag): Adjust to above renaming.
+	* sem_prag.adb (Analyze_Pragma): Likewise.
+	(Sig_Flags): Likewise.
+
 2025-09-09  Gary Dismukes  <dismukes@adacore.com>
 
 	* exp_ch4.adb (Expand_N_Op_Eq): Check for warning about call to
diff --git a/gcc/c/ChangeLog b/gcc/c/ChangeLog
index 36f7c9d9974a..8ee4008826f1 100644
--- a/gcc/c/ChangeLog
+++ b/gcc/c/ChangeLog
@@ -1,3 +1,19 @@
+2025-09-10  Martin Uecker  <uecker@tugraz.at>
+
+	* c-tree.h: Add new macro C_DECL_NONLOCAL_CONTEXT and prototype
+	for mark_decl_used.
+	* c-typeck.cc (mark_decl_used): New function.
+	(function_to_pointer_conversion): Mark exempt functions.
+	(record_maybe_used_decl): Add `address' parameter.
+	(build_external_ref): Change to mark_decl_used.
+	(pop_maybe_used): Call mark_decl_used.
+	(c_mark_addressable): Ditto.
+	(c_finish_goto_label): Ditto.
+	(c_finish_return): Add warning.
+	* c-decl.cc (declspecs_add_type): Ditto.
+	(grokdeclarator): Don't set C_DECL_REGISTER on function
+	declarators.
+
 2025-09-08  H.J. Lu  <hjl.tools@gmail.com>
 
 	PR c/107419
diff --git a/gcc/cp/ChangeLog b/gcc/cp/ChangeLog
index a86e2c215416..5853607f7030 100644
--- a/gcc/cp/ChangeLog
+++ b/gcc/cp/ChangeLog
@@ -1,3 +1,14 @@
+2025-09-10  Nathaniel Shead  <nathanieloshead@gmail.com>
+
+	PR c++/121859
+	* constraint.cc (maybe_diagnose_standard_trait): Check if expr
+	is non-null.
+
+2025-09-10  Jakub Jelinek  <jakub@redhat.com>
+
+	* mangle.cc (write_real_cst): Mangle Intel/Motorola extended
+	80-bit formats using 20 hex digits instead of 24 or 32.
+
 2025-09-09  Nathaniel Shead  <nathanieloshead@gmail.com>
 
 	PR c++/99682
diff --git a/gcc/testsuite/ChangeLog b/gcc/testsuite/ChangeLog
index 9a960dc33cee..401b0eea6ed7 100644
--- a/gcc/testsuite/ChangeLog
+++ b/gcc/testsuite/ChangeLog
@@ -1,3 +1,79 @@
+2025-09-10  Joseph Myers  <josmyers@redhat.com>
+
+	* gcc.dg/c2y-function-qual-1.c, gcc.dg/c2y-incomplete-1.c,
+	gcc.dg/c2y-inline-1.c, gcc.dg/c2y-pointer-1.c,
+	gcc.dg/c2y-register-array-1.c, gcc.dg/c2y-storage-class-1.c,
+	gcc.dg/c2y-struct-empty-1.c: New tests.
+
+2025-09-10  Peter Bergner  <bergner@tenstorrent.com>
+
+	PR target/121878
+	* gcc.target/riscv/pr121878.c: New test.
+
+2025-09-10  Juergen Christ  <jchrist@linux.ibm.com>
+
+	* gcc.dg/vect/nodump-extractlast-1.c: New test.
+
+2025-09-10  Martin Uecker  <uecker@tugraz.at>
+
+	* gcc.dg/Wreturn-nested-1.c: New test.
+	* gcc.dg/Wreturn-nested-2.c: New test.
+	* gcc.dg/Wtrampolines-2.c: New test.
+	* gcc.dg/Wtrampolines-3.c: New test.
+
+2025-09-10  Paul-Antoine Arras  <parras@baylibre.com>
+
+	* gcc.target/riscv/rvv/autovec/vx_vf/vf-1-f16.c: Add vfwsub.wf.
+	* gcc.target/riscv/rvv/autovec/vx_vf/vf-1-f32.c: Likewise.
+	* gcc.target/riscv/rvv/autovec/vx_vf/vf-2-f16.c: Likewise.
+	* gcc.target/riscv/rvv/autovec/vx_vf/vf-2-f32.c: Likewise.
+	* gcc.target/riscv/rvv/autovec/vx_vf/vf-3-f16.c: Likewise.
+	* gcc.target/riscv/rvv/autovec/vx_vf/vf-3-f32.c: Likewise.
+	* gcc.target/riscv/rvv/autovec/vx_vf/vf-4-f16.c: Likewise.
+	* gcc.target/riscv/rvv/autovec/vx_vf/vf-4-f32.c: Likewise.
+	* gcc.target/riscv/rvv/autovec/vx_vf/vf_binop.h
+	(DEF_VF_BINOP_WIDEN_CASE_2, DEF_VF_BINOP_WIDEN_CASE_3): Swap operands.
+	* gcc.target/riscv/rvv/autovec/vx_vf/vf_vfwsub-run-2-f16.c: New test.
+	* gcc.target/riscv/rvv/autovec/vx_vf/vf_vfwsub-run-2-f32.c: New test.
+
+2025-09-10  Nathaniel Shead  <nathanieloshead@gmail.com>
+
+	PR c++/121859
+	* g++.dg/cpp2a/concepts-traits5.C: New test.
+
+2025-09-10  Jakub Jelinek  <jakub@redhat.com>
+
+	* lib/lto.exp (lto-execute-1): Search for _1.* etc. files
+	only with a list of known extensions.
+
+2025-09-10  Jakub Jelinek  <jakub@redhat.com>
+
+	PR middle-end/121828
+	* gcc.dg/bitint-126.c: New test.
+
+2025-09-10  Jakub Jelinek  <jakub@redhat.com>
+
+	PR middle-end/121831
+	* g++.dg/lto/pr121831_0.C: New test.
+	* g++.dg/lto/pr121831_1.C: New test.
+
+2025-09-10  Juergen Christ  <jchrist@linux.ibm.com>
+
+	* gcc.dg/vect/pr109011-2.c: Fix expected outcome.
+	* gcc.dg/vect/pr109011-4.c: Fix expected outcome.
+	* gcc.target/s390/ffs-1.c: New test.
+
+2025-09-10  Jakub Jelinek  <jakub@redhat.com>
+
+	* g++.target/i386/mangle-ldbl-1.C: New test.
+	* g++.target/i386/mangle-ldbl-2.C: New test.
+	* g++.target/m68k/mangle-ldbl-1.C: New test.
+	* g++.target/m68k/mangle-ldbl-2.C: New test.
+
+2025-09-10  Maximilian Immanuel Brandtner  <maxbr@linux.ibm.com>
+
+	* gcc.target/s390/vector/vec-extract-3.c: New test.
+
 2025-09-09  Nathaniel Shead  <nathanieloshead@gmail.com>
 
 	PR c++/99682
diff --git a/libstdc++-v3/ChangeLog b/libstdc++-v3/ChangeLog
index 1948f39fec3a..4718ea6a1633 100644
--- a/libstdc++-v3/ChangeLog
+++ b/libstdc++-v3/ChangeLog
@@ -1,3 +1,56 @@
+2025-09-10  Jonathan Wakely  <jwakely@redhat.com>
+
+	* include/bits/unique_ptr.h: Remove blank line.
+
+2025-09-10  Jonathan Wakely  <jwakely@redhat.com>
+
+	* include/std/functional (boyer_moore_searcher::operator()): Add
+	static_assert.
+	(boyer_moore_horspool_searcher::operator()): Likewise.
+	* testsuite/20_util/function_objects/121782.cc: New test.
+
+2025-09-10  Luc Grosheintz  <luc.grosheintz@gmail.com>
+
+	* include/std/mdspan (_ExtentsStorage::_Base): New name for
+	_S_base.
+	(_ExtentsStorage::_Storage): New name for _S_storage.
+	(extents::_Storage): New name for _S_storage.
+	(layout_stride::mapping::_Strides): New name for
+	_S_stries_t.
+	* testsuite/23_containers/mdspan/class_mandate_neg.cc: Update
+	test to the new error message.
+
+2025-09-10  Luc Grosheintz  <luc.grosheintz@gmail.com>
+
+	* include/std/span (__integral_constant_like): Use
+	remove_cvref_t before checking if _Tp::value is boolean.
+	* testsuite/23_containers/mdspan/extents/misc.cc: Update test.
+	* testsuite/23_containers/mdspan/mdspan.cc: Ditto.
+	* testsuite/23_containers/span/deduction.cc: Ditto.
+
+2025-09-10  Tomasz Kamiński  <tkaminsk@redhat.com>
+
+	PR libstdc++/121765
+	* include/std/format (__format::_Drop_iter): Define.
+	(_Iter_for_t::type): Change alias to _Drop_iter.
+	(__format::__format_padded): Return __fc.out() for
+	_Drop_iter.
+	* testsuite/std/format/pr121765.cc: New test.
+
+2025-09-10  Tomasz Kamiński  <tkaminsk@redhat.com>
+
+	* doc/html/manual/status.html: Regenerate.
+	* doc/xml/manual/status_cxx2020.xml: Add more entires.
+
+2025-09-10  Tomasz Kamiński  <tkaminsk@redhat.com>
+
+	* doc/html/index.html: Regenerated.
+	* doc/html/manual/index.html: Regenerated.
+	* doc/html/manual/intro.html: Regenerated.
+	* doc/html/manual/status.html: Regenatered.
+	* doc/xml/manual/status_cxx2020.xml: Add iso.2020.specific
+	section with atomic_ref documentation.
+
 2025-09-09  Jonathan Wakely  <jwakely@redhat.com>
 
 	* include/std/type_traits (_CwFixedValue::_S_type): Rename to


More information about the Libstdc++-cvs mailing list