r268532 - in /trunk/libstdc++-v3: ChangeLog inc...

glisse@gcc.gnu.org glisse@gcc.gnu.org
Tue Feb 5 09:33:00 GMT 2019


Author: glisse
Date: Tue Feb  5 09:33:36 2019
New Revision: 268532

URL: https://gcc.gnu.org/viewcvs?rev=268532&root=gcc&view=rev
Log:
Rename __is_trivially_relocatable to __is_bitwise_relocatable.

2019-02-05  Marc Glisse  <marc.glisse@inria.fr>

	PR libstdc++/87106
	* include/bits/stl_uninitialized.h (__is_trivially_relocatable):
	Rename...
	(__is_bitwise_relocatable): ... to this.
	(__relocate_a_1): Adapt.
	* include/bits/stl_deque.h (__is_trivially_relocatable): Rename...
	(__is_bitwise_relocatable): ... to this.

Modified:
    trunk/libstdc++-v3/ChangeLog
    trunk/libstdc++-v3/include/bits/stl_deque.h
    trunk/libstdc++-v3/include/bits/stl_uninitialized.h



More information about the Libstdc++-cvs mailing list