r141109 - in /branches/lto: gcc/ChangeLog.lto g...

dnovillo@gcc.gnu.org dnovillo@gcc.gnu.org
Tue Oct 14 14:50:00 GMT 2008


Author: dnovillo
Date: Tue Oct 14 14:50:35 2008
New Revision: 141109

URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=141109
Log:
gcc/ChangeLog.lto

2008-10-13  Ollie Wild  <aaw@google.com>

	* c.opt (flto): Switch variable name to flag_lto.
	(fwhopr): New option.
	* collect2.c (enum lto_mode_d): Rename LTO_MODE_WPA to LTO_MODE_WHOPR.
	(lto_o_file): Remove.
	(lto_o_files): New variable.
	(collect_exit): Replace lto_o_file with lto_o_files.
	(handler): Replace lto_o_file with lto_o_files.
	(maybe_run_lto_and_relink): Add support for -fwhopr.
	(main): Replace -fwpa with -fwhopr.
	(maybe_unlink_list): New function.
	* gcc.c (gcc_lto_option_t): Remove.
	(lto_single): New variable.
	(LINK_COMMAND_SPEC): Add flto and fwhopr.  Remove link_lto_options.
	(cc1_non_lto_options): Rename as cc1_options.
	(cc1_options): Remove.
	(lto1_options): Remove.
	(link_lto_options): Remove.
	(invoke_lto_single): Replace lto-option with lto-single.  Add -flto.
	Replace lto1_options with cc1_options.
	(static_specs): Remove cc1_non_lto_options, lto1_options, and
	link_lto_options.
	(static_spec_functions): Replace lto-option with lto-single.
	(process_command): Set lto_single.  Remove cases for -flto, -fwpa, and
	-fltrans.
	(lto_option_spec_function): Remove.
	(lto_single_spec_function): New function.
	* c-opts.c (c_common_post_options): Add -flto/-fwhopr validation.
	* flags.h (flag_generate_lto): New variable declaration.
	* toplev.c (flag_generate_lto): New variable definition.

gcc/lto/ChangeLog

2008-10-13  Ollie Wild  <aaw@google.com>

	* lang-spec.h (@lto): Replace lto1_options with cc1_options.
	* lto.c (lto_execute_ltrans): Add "-fno-wpa -fltrans -xlto" to CFLAGS.
	* ltrans-driver (LTRANS_FLAGS): Remove.

gcc/testsuite/ChangeLog.lto

2008-10-13  Ollie Wild  <aaw@google.com>
	    Diego Novillo  <dnovillo@google.com>

	* lib/c-torture.exp: Add "-O2 -fwhopr" and "-O0 -fwhopr".
	* lib/gcc-dg.exp: Likewise.


libstdc++-v3/ChangeLog.lto

2008-10-14  Diego Novillo  <dnovillo@google.com>

	* scripts/testsuite_flags.in: Replace -flto with -fwhopr.



Modified:
    branches/lto/libstdc++-v3/ChangeLog.lto
    branches/lto/libstdc++-v3/scripts/testsuite_flags.in

Changes in other areas also in this revision:
Modified:
    branches/lto/gcc/ChangeLog.lto
    branches/lto/gcc/c-opts.c
    branches/lto/gcc/c.opt
    branches/lto/gcc/collect2.c
    branches/lto/gcc/flags.h
    branches/lto/gcc/gcc.c
    branches/lto/gcc/lto/ChangeLog
    branches/lto/gcc/lto/lang-specs.h
    branches/lto/gcc/lto/lto.c
    branches/lto/gcc/lto/ltrans-driver
    branches/lto/gcc/testsuite/ChangeLog.lto
    branches/lto/gcc/testsuite/lib/c-torture.exp
    branches/lto/gcc/testsuite/lib/gcc-dg.exp
    branches/lto/gcc/toplev.c



More information about the Libstdc++-cvs mailing list