cross-compilation & libgccjit

Basile Starynkevitch basile@starynkevitch.net
Thu Jan 1 00:00:00 GMT 2015


On 07/15/2015 17:03, David Malcolm wrote that he is working on:
> (a) libgccjit: adding support for cross-compilation (perhaps with a 
> gcc_jit_target type).

If you do that, you really should change the name of your library. By 
definition Just-In-Time compilation is
with the host same as the target and forbids the idea of 
cross-compilation (which is always Ahead Of Time).

Perhaps your library should be renamed as libgccgeneratecode and sit in 
gcc/generate/

That name is not sexy, but I really believe that cross-compilation 
cannot be Just In Time by definition; so please don't call your library 
libgccjit (or anything containing JIT acronym) if it is not related to 
Just In Time compilation, see
https://en.wikipedia.org/wiki/Just-in-time_compilation


Please, please, don't name gccjit something which is not only for Just 
In Time. Find another name!

Cheers

-- 
Basile STARYNKEVITCH         http://starynkevitch.net/Basile/
email: basile<at>starynkevitch<dot>net mobile: +33 6 8501 2359
8, rue de la Faiencerie, 92340 Bourg La Reine, France
*** opinions {are only mine, sont seulement les miennes} ***



More information about the Jit mailing list