[PATCH 06/08] Avoid overuse of name "buffer" in tree-pretty-print.c

Jeff Law law@redhat.com
Wed Jan 1 00:00:00 GMT 2014


On 11/25/14 18:39, David Malcolm wrote:
> Various functions in tree-pretty-print.c take a param
>    pretty_printer *buffer
> and there's also a static pretty_printer *buffer;
>
> Additionally, pretty_printer instances are not buffers; they
> *contain* buffers (inasmuch as they have a field "buffer").
>
> This patch renames such params from "buffer" to "pp", and the static
> "buffer" to "tree_pp" to make it easier to tell what we're dealing
> with (a param, a file-static, or a buffer).
>
> gcc/ChangeLog:
> 	* tree-pretty-print.c (INDENT): Rename "buffer" to "pp".
> 	(NIY): Likewise.
> 	(buffer): Rename this variable to...
> 	(tree_pp): ...this.
>
> 	(do_niy): Rename param from "buffer" to "pp".
> 	(dump_decl_name): Likewise.
> 	(dump_function_name): Likewise.
> 	(dump_function_declaration): Likewise.
> 	(dump_array_domain): Likewise.
> 	(dump_omp_clause): Likewise.
> 	(dump_omp_clauses): Likewise.
> 	(dump_location): Likewise.
> 	(dump_block_node): Likewise.
> 	(dump_generic_node): Likewise.
> 	(print_declaration): Likewise.
> 	(print_struct_decl): Likewise.
> 	(print_call_name): Likewise.
> 	(pretty_print_string): Likewise.
> 	(newline_and_indent): Likewise.
>
> 	(print_generic_decl): Update for renaming of "buffer" to
> 	"tree_pp".
> 	(print_generic_stmt): Likewise.
> 	(print_generic_stmt_indented): Likewise.
> 	(print_generic_expr): Likewise.
> 	(maybe_init_pretty_print): Likewise.
OK.
jeff



More information about the Jit mailing list