JAAS on MacOSX

Clemens Eisserer linuxhippy@web.de
Fri Nov 5 21:10:00 GMT 2004


Thanks a lot for you help!

>The class "com.sun.security.auth.module.UnixLoginModule" is available by
>default on Mac OS X.  At least it is on 10.3.5 + Java 1.4.2Update2, and on
>10.2.3 + Java 1.4.1.  It's not present under Java 1.3.1, that I saw.  I
>haven't checked other configurations, so you should probably do that for
>the configurations and versions you want to support.
>  
>
Well thats very fine! IBM has it located somewhere in com.ibm.... which 
is ugly for me cause I have to switch.
I expected it somewhere in com.apple but nice that its fully compatible!

> <>Try it. It may work only with specific versions of Java, or across the
> board (1.3.*, 1.4.*).

The reason why I am asking is that I still go to school and OSX is quite 
too expensive for me.
I use Linux but even compared to MS-OS (which is at least 5y up to date) 
Apple stops supporting older OSses even after a year!
Have a look, latest Safari and Java both need 10.3 - no luck with 10.2 
which is maybe 18 months old.

This is really sad, but its the thruth - its soo good but just too 
expensive for me :-(

Thanks a lot for your help, lg Clemens



More information about the Java mailing list