Running Eclipse with 3.4's gij

Anthony Green green@redhat.com
Fri Mar 26 06:42:00 GMT 2004


Hey Tom - 

	To run Eclipse with 3.4's gij, you will probably want to set the
gnu.gcj.runtime.VMClassLoader.library_control property...

GCJ_PROPERTIES="gnu.gcj.runtime.VMClassLoader.library_control=never" ~/eclipse/eclipse/eclipse -vm gij

	Selecting the Help menu fires up tomcat and, on my system, libgcj
starts loading the RHEL3 versions of lib-org-apache-*, etc.
which are incompatible.

	I was able to run Eclipse with no obvious problems after setting this
property.

	I realize that some day we may have a new ABI that should solve
problems like this, but I'm thinking that it might also make sense for
libgcj to only load libraries from a compiler specific directory.  What
do you think?

AG

-- 
Anthony Green <green@redhat.com>
Red Hat, Inc.



More information about the Java mailing list