error: Can't find method `getLastSelectedPathComponent()' in type `javax.swing.JTree'

Thomas Léauté thleaute@csail.mit.edu
Tue Aug 31 18:26:00 GMT 2004


Hi

I am completely new to gcj and I'm only a beginner in java, so I 
apologize in advance if I sound a little naive...
I am trying to call java methods from C++. I have looked into the java 
JNI, but it seems to me that it is only usable if the main() function 
is written in java, right?...
So when I heard about gcj and libgcj, I thought it would be the answer 
to my problem. I am trying to use gcj to compile my java legacy code, 
but I get the following error:

error: Can't find method `getLastSelectedPathComponent()' in type 
`javax.swing.JTree'

I also get:

error: Can't find method 
`scrollPathToVisible(Ljavax/swing/tree/TreePath;)' in type 
`javax.swing.JTree'

Is it because this is not supported yet? Or did I do something wrong 
when I installed gcj?... I am on Mac OS 10.3. I followed the 
instructions at http://hpc.sourceforge.net/ to install the gcj 3.5 
binaries. I also tried to compile them as described at 
http://users.bestweb.net/~john3g/gcj_osx/gcj_on_osx.html , but when I 
tried to build them, I got:

configure: error:
The following requested languages were not found: c++ java
The following languages were available: c treelang

So I'm really starting to wonder if I didn't do anything wrong when I 
first installed gcj 3.5. Or does gcj 3.5 require g++ 3.5? (g++ 
--version returns "g++ (GCC) 3.3 20030304 (Apple Computer, Inc. build 
1666)")

Thanks a lot for your help

Thomas

" We know what we think we know,
    Just as we don't know what we want to know "
                         Oscar Wilde
                         The Picture of Dorian Gray



More information about the Java mailing list