installation and compile problem

Ray Auge rayauge@doublebite.com
Thu Oct 9 13:41:00 GMT 2003


Hello all,

I downloaded the 3.3.1 gcc tarball, 

- since I'm on ppc, I set "can_unwind_signal=no" for powerpc*-linux* 
- default install dir is /usr/local
- configured it via the install notes ( ../gcc-3.3.1/configure
	--program-suffix=-3.3.1 ),
- build it ( make bootstrap ), 
- tested it ( make -k check ),
- installed it ( su -c "make install" ),

As a test, I tired a few simple classes (no imports), worked fine.
I then tried to compile one of the Xerces sample xml parsers (
DocumentTracer.java ) which actually only imports org.xml.sax classes
(does not use any Xerces classes)...

This is what I get:

>/usr/local/bin/gcj-3.3.1 -fPIC -fjni -g -O -o DocumentTracer
--main=DocumentTracer  DocumentTracer.java
/tmp/ccVDxVEA.o(.text+0x54): In function
`DocumentTracer::DocumentTracer[in-charge]()':
/home/com_/Development/test-code/xerces-samples/samples/sax/DocumentTracer.java:158: undefined reference to `org::xml::sax::helpers::DefaultHandler::DefaultHandler[in-charge]()'
/tmp/ccVDxVEA.o(.text+0x3870): In function
`DocumentTracer::main(JArray<java::lang::String*>*)':
/home/com_/Development/test-code/xerces-samples/samples/sax/DocumentTracer.java:815: undefined reference to `org::xml::sax::helpers::XMLReaderFactory::createXMLReader(java::lang::String*)'
/tmp/ccVDxVEA.o(.text+0x388c):/home/com_/Development/test-code/xerces-samples/samples/sax/DocumentTracer.java:819: undefined reference to `org::xml::sax::helpers::ParserFactory::makeParser(java::lan
etc...

Note that I had previously working libgcj.so.3 with the prior version of
gcj, the one that came standard with the YellowDog 3.0 distro installed
at /usr/bin/gcj. It all worked fine, but I wanted the more recent xml
support so tired to move to libgcj.so.4.

Can someone just point me in the right direction...

Thanks,
Ray Auge



More information about the Java mailing list