CVS error on ppc

Eric Blake ebb9@email.byu.edu
Wed May 1 09:26:00 GMT 2002


You're not the only one.  Something is wrong in the Makefile script,
because I got the same error on a RedHat box:

cvs [update aborted]: reading libjava/sysdep/i386/locks.h: Too many levels of symbolic links

Basically, something in the Makefile is linking
libjava/sysdep/<arch>/locks.h to itself, causing an infinite link
recursion. It is also affecting compilation:

...
linking ../../../gcc/libjava/sysdep/i386/locks.h to sysdep/locks.h
configure: error: ../../../gcc/libjava/sysdep/i386/locks.h: File not found
make[2]: *** [Makefile] Error 1

I'm not sure who is responsible, but would you like to file a
high-priority PR since you found it first? I'm cc'ing the gcc list, in
case anyone knows what went wrong.


> From: Nic Ferrier <nferrier at tapsellferrier dot co dot uk>
> To: <java at gcc dot gnu dot org>
> Date: 01 May 2002 15:09:39 +0100
> 
> Something strange just happened on my PPClinux box... I was just
> trying a cvs update on the gcc tree (the branch) and I got this:
> 
> cvs [update aborted]: reading libjava/sysdep/powerpc/locks.h: Too many levels of symbolic links
> nferrier@imac:~/projects/gnu/gcc/gcc-cvs$ Write failed flushing stdout buffer.
> write stdout: Broken pipe
> 
> Bizzare! It worked fine last night (though the build didn't run,
> which is why I was updating today - so I could report the fault).
> 
> 
> Nic

----
Eric Blake       ebb9@email.byu.edu



More information about the Java mailing list