patch#3 disable the libgcj interpreter under darwin

Bryce McKinlay bryce@waitaki.otago.ac.nz
Wed Jan 2 15:07:00 GMT 2002


Tom Tromey wrote:

>>>>>>"Andreas" == Andreas Tobler <toa@pop.agri.ch> writes:
>>>>>>
>
>Andreas>                 * configure.host
>Andreas> 			disable the interpreter for darwin(ppc)
>
>Why do we need to disable the interpreter here?
>Does Darwin have an ABI that isn't supported by libffi?
>Or do we instead just need to add some configury to libffi?
>

libffi now has Darwin ABI support (from John Hornkvist) but it doesn't 
support closures yet. So, the Darwin support is good enough for 
reflection but not for the interpreter. This is something I'll probibly 
try to implement once all the other issues with Darwin are resolved.

regards

Bryce.




More information about the Java mailing list