successful(?) build of libjava on mips-sgi-irix6.5

Rainer Orth ro@TechFak.Uni-Bielefeld.DE
Mon Feb 11 12:08:00 GMT 2002


Alexandre Oliva writes:

> On Feb  8, 2002, Rainer Orth <ro@TechFak.Uni-Bielefeld.DE> wrote:
> 
> > Philip Goisman <goisman@physics.arizona.edu> writes:
> >> Is there a solution to this error such that libgcj will get 
> >> built on mips-sgi-irix6.5, or, is it still true that libgcj still
> >> cannot be built on mips-sgi-irix6.5?
> 
> > I've documented a workaround in
> 
> > 	http://gcc.gnu.org/install/specific.html#mips-sgi-irix6
> 
> > that allowed me to build libgcj on mips-sgi-irix6.[25].  Of course, the
> > underlying problem should be fixed in libtool.
> 
> This could only be fixed in libtool if libtool got a chance to run.
> Clearly, this is not the case, as it is make that is having trouble to
> run a shell that would then invoke libtool.

right, but apart from this, I ran into another problem with the way libtool
incrementally creates shared objects on systems with command line length
limits: it incrementally adds object files to an intermediary object within
the limits of command line length until it finally creates a shared object
from that single object file.  This may run into an IRIX ld problem

	http://gcc.gnu.org/ml/gcc/2001-06/msg01472.html

which (according to the IRIX 6 dso(5) man page, FREQUENTLY ASKED QUESTIONS,
22.) can be avoided by creating the shared object from several smaller
object files instead of one large one.

I.e. instead of (in outline)

	ld -r -o libgcj1.o <first object sublist>
        ld -r -o libgcj2.o libgcj1.o <second object sublist>
	ld -o libgcj.so libgcj2.o

it should probably do

	ld -r -o libgcj1.o <first object sublist>
        ld -r -o libgcj2.o <second object sublist>
	ld -o libgcj.so libgcj1.o libgcj2.o

I think I tried doing this manually in the past, but never got around to
provide a proper bug report or patch for this problem.

	Rainer



More information about the Java mailing list