Java programs coredump on sparc Solaris 2.6

Weiqi Gao weiqigao@networkusa.net
Sun May 20 05:11:00 GMT 2001


On 20 May 2001 00:42:18 -0400, Jeff Sturm wrote:
> 
> On 19 May 2001, Weiqi Gao wrote:
> > Am I seeing something different from everyone else?  Are Java programs
> > working on anyone elses sparc Solaris box?
> 
> I've had a Solaris build working recently, though I haven't tried since
> the EH merge.
> 
> Are you using GNU binutils?  You may need to install them, and use
> --with-as=<path to GNU as> and --with-ld=<path to GNU ld> when you
> configure GCC.

I'm using GNU binutils 2.11, and I'm specifying
--with-as=/path/to/gnu/as and --with-ld=/path/to/gnu/ld when I
configured GCC.  What I didn't do was to also specify --with-gnu-as and
--with-gnu-ls as suggested in a previous post.

One post on the gcc list,
http://gcc.gnu.org/ml/gcc/2001-05/msg00475.html , seems to suggest a
development version og GNU Assembler is required for certain platforms.
I don't know if that includes sparc Solaris.

At any rate, I'll watch the list and try again with a later snapshot.

Thanks
-- 
Weiqi Gao
weiqigao@networkusa.net



More information about the Java mailing list