libffi "configure: warning: This is beta code."

Gerald Pfeifer pfeifer@dbai.tuwien.ac.at
Sat May 5 02:06:00 GMT 2001


Once more, a bootstrap on sparc-sun-solaris2.8 failed for me today, and
while investigating, I noticed the following lines in my build log:

configure: warning: ***********************************************************
configure: warning: ***********************************************************
configure: warning: This is beta code.  If you're looking for a stable release
configure: warning: then use the most recent one - libffi-1.20.
configure: warning: ***********************************************************
configure: warning: ***********************************************************

I consider this inappropriate for a (soon to be) released version of GCC.

Either we have to use a stable version of libffi or, if we need to use a
snapshot, we should disable this warning.

Regular users of GCC should *not* be exposed to such warnings, IMHO.

Gerald
-- 
Gerald "Jerry" pfeifer@dbai.tuwien.ac.at http://www.dbai.tuwien.ac.at/~pfeifer/



More information about the Java mailing list