Name mangling once again

Martin Kahlert martin.kahlert@infineon.com
Fri Feb 2 07:57:00 GMT 2001


H!
I reported a problem with unresolved symbols on Jan, 31 and
Alexandre Petit-Bianco told me, that it went away after updating
his tree. I completely checked out the gcc tree today (Feb, 2) but
the problem is not solved at all.

The (hopefully) relevant nm output is:

nm VHDL/VG/VCG/LINUX_GCC/VCG_Node.o | grep VCGA_Title | grep " U "

U _ZN4VHDL2VG3VCG10VCGA_Title6class$E
U _ZN4VHDL2VG3VCG10VCGA_TitleC1EPN4java4lang6StringE
U _ZN4VHDL2VG3VCG8VCG_Node28class$VHDL$VG$VCG$VCGA_TitleE  <== looks strange


nm VHDL/VG/VCG/LINUX_GCC/VCGA_Title.o | grep VCGA_Title | grep " [TD] "

T _GLOBAL_.I._ZN4VHDL2VG3VCG10VCGA_TitleC1EPN4java4lang6StringE
D _ZN4VHDL2VG3VCG10VCGA_Title6class$E
T _ZN4VHDL2VG3VCG10VCGA_TitleC1EPN4java4lang6StringE
D _ZTVN4VHDL2VG3VCG10VCGA_TitleE

I compiled both object files from .class files, i do not have .java sources
for them.

Where could the symbol
_ZN4VHDL2VG3VCG8VCG_Node28class$VHDL$VG$VCG$VCGA_TitleE
come from?

The error output reads:
/home/kahlert/LOCAL/TMC_JAVA/VHDL/VG/VCG/VCG_Node.class(.text+0x3d4): \
undefined reference to `VHDL::VG::VCG::VCG_Node::class$VHDL$VG$VCG$VCGA_Title '

    I was not able to produce anything like this name
(i tried derivation from another class, using it as a class member, local var
and as parameter in a constructor).

Any hints?

Thanks,
Martin.


-- 
The early bird gets the worm. If you want something else for       
breakfast, get up later.


More information about the Java mailing list