gcc.3.0.1 08/13 on Alpha Tru64 v 5.0

Antonio Ake ake@ecn.purdue.edu
Thu Aug 16 21:03:00 GMT 2001


Much better building process compared with 07/02 version:
But, 4 problems detected:
1. libstdc++ v3.0 still misdetected. PR created in libstdc++ group.
2. Again linker doesn't want to compile to many files.(
http://gcc.gnu.org/ml/java/2001-07/msg00172.html )
I tried to use --disable-java-awt but it is not
working, I modified Makefile.in to disabled it.
3. When it is compiling natFirstThread.cc. I have this message error.
natFirstThread.o
../../../gcc-3.0.1-20010813/libjava/gnu/gcj/runtime/natFirstThread.cc: In
   function `jint _JNI_OnLoad(JavaVM*, void*)':
../../../gcc-3.0.1-20010813/libjava/gnu/gcj/runtime/natFirstThread.cc:50:
warning: unused
   parameter `JavaVM*vm'
../../../gcc-3.0.1-20010813/libjava/gnu/gcj/runtime/natFirstThread.cc: In
   member function `virtual void gnu::gcj::runtime::FirstThread::run()':
../../../gcc-3.0.1-20010813/libjava/gnu/gcj/runtime/natFirstThread.cc:79:
invalid
   use of undefined type `class java::lang::UnsatisfiedLinkError'
../../../gcc-3.0.1-20010813/libjava/gcj/javaprims.h:199: forward
declaration of
   `class java::lang::UnsatisfiedLinkError'

My configure command is: ../gcc-3.0.1-20010813/configure
--host=alphaev56-dec-osf5.0 --prefix=/usr/users/ake/gcc18
--disable-threads --enable-libgcj --without-x --disable-java-net
--disable-jvmpi

(Functional behaviour)
4. There are still internal message errors when I tried to compile
with -O2, I have to change it to -O1 when I compiling some files.

Regards



More information about the Java mailing list