JvSynchronize nitpick
Per Bothner
per@bothner.com
Tue Mar 28 20:47:00 GMT 2000
Paul Fisher <pnfisher@redhat.com> writes:
> Is there any reason why we can't go ahead and add this? It seems like
> a perfect solution.
It's a ok solution to a non-problem, I feel.
The only real problem I see with the existing JvSynchronized
helper class is the need to specify a dummy variable name.
I'm not sure I like adding a `synchronized' macro: macros are to be
avoided in C++, because they violate the other name-scoping rules.
Especially, a name like `synchronized', which might easily conflict
with other head files. Still, if we want to avoid having to name a
dummy variable, we need to use a macro. However. I think it should
be something following the Jv-prefix convention.
--
--Per Bothner
per@bothner.com http://www.bothner.com/~per/
More information about the Java
mailing list