For the current interface dispatch solution, I believe it would be better to use a hash that not only includes the method name's utf8 hash, but also some bits from the class. This should reduce the likelyhood of constant conflict misses for invocations of the same interface method on different run-time types, which is likely to be common. - Godmar