proposed patch for PR 72 (method lookup in interfaces)

Per Bothner per@bothner.com
Wed Nov 3 14:43:00 GMT 1999


Godmar Back <gback@cs.utah.edu> writes:

> -lookup_java_method (clas, method_name, method_signature)
> -     tree clas, method_name, method_signature;
> +lookup_java_method (clazz, method_name, method_signature)
> +     tree clazz, method_name, method_signature;

Can we avoid changing one ugly formal-parameter-name
for one arguably worse?  How about instead replacing
`clas' by something meaningful, like `receiver_class'
(or whatever terminology most matches the JLS)?
-- 
	--Per Bothner
per@bothner.com   http://www.bothner.com/~per/


More information about the Java mailing list