Trouble installing libgcj on i686-pc-linux-gnu (RedHat 6.0)

Sandro Hawke
Sat May 8 08:18:00 GMT 1999

Tom> egcs might have changed how it decides when to emit a vtable into the
Tom> .o file.  I think that could cause the problem you are seeing.

Ah yes.  I see Mark Mitchell says he broke something about vtables on
4-30 and then (supposedly) fixed it again on 5-01.
( )

So I tried egcs from 04-20, 04-26, 04-28, ..., and I don't think
mmitchell's work caused the problem.  04-28 still has the vtable bug.
(If I go back any farther, older bugs start to reappear that break the
compile before getting to natObject.)

Tom> I'd rather work it out now.  It works every day for me, and I don't
Tom> have a clue how I would reproduce your problems.
Tom> I doubt the problem is with glibc, since the problem seems to be
Tom> conflicting definitions of the Object and Class vtables.

What else could it be?     (any of the 4x10^9 bits in the OS
distribution, yes....)

I'm going to try it with RedHat 5.2 instead.   It probably wont help
find the bug, but maybe it'll work, at least.   (vmware - the great
workaround hack.)

    -- sandro

More information about the Java mailing list