[Bug java/60261] [4.9 Regression] Weird java install with --enable-version-specific-runtime-libs

rguenth at gcc dot gnu.org gcc-bugzilla@gcc.gnu.org
Tue Feb 18 11:47:00 GMT 2014


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=60261

--- Comment #3 from Richard Biener <rguenth at gcc dot gnu.org> ---
libjavamath uses

nativeexeclib_LTLIBRARIES = libjavamath.la

and inside classpath

             nativeexeclibdir='${toolexeclibdir}/gcj-'`cat
${srcdir}/../../gcc/BASE-VER`-`awk -F: '/^[[^#]].*:/ { print $1 }'
${srcdir}/../libtool-version`

(eh)

thus not multilib aware.  4.8 put the gcj-4.8 dir in /usr/lib64/, thus not
aware of version-specific dirs and it contained

classmap.db  libjavamath.la  libjavamath.so  libjvm.la  libjvm.so

Why wasn't that "version-specific" enough?  (it has the -sover suffix?)
If it wasn't enough the whole stuff should be below
/usr/lib64/gcc/x86_64-suse-linux/4.9/ which means both path variants used
by 4.9 currently are bogus.

I think given the current state of libjava maintainance reverting the
change is the best.



More information about the Java-prs mailing list