[Bug libgcj/24403] --enable-java-awt=qt fails to build

bero at arklinux dot org gcc-bugzilla@gcc.gnu.org
Thu Nov 3 09:29:00 GMT 2005



------- Comment #2 from bero at arklinux dot org  2005-11-03 09:29 -------
After hacking the makefiles to get it to build anyway, trying to run an AWT
application aborts on startup because gcj renames libqtpeer.so to
lib-gnu-java-awt-peer-qt.so, while gnu/java/awt/peer/qt/QtToolkit.java still
tries to load libqtpeer.

This patch is needed:
--- gcc/libjava/classpath/gnu/java/awt/peer/qt/QtToolkit.java.ark      
2005-11-
03 09:57:52.000000000 +0100
+++ gcc/libjava/classpath/gnu/java/awt/peer/qt/QtToolkit.java   2005-11-03
09:58
:05.000000000 +0100
@@ -135,7 +135,7 @@
   {
     eventQueue = new EventQueue();
     repaintThread = new QtRepaintThread();
-    System.loadLibrary("qtpeer");
+    System.loadLibrary("-gnu-java-awt-peer-qt");

     String theme = null;
     try


-- 


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=24403



More information about the Java-prs mailing list