[Bug libgcj/23216] IncompatibleClassChangeError when Using Java-Gnome

ajocksch at redhat dot com gcc-bugzilla@gcc.gnu.org
Tue Aug 23 16:05:00 GMT 2005


------- Additional Comments From ajocksch at redhat dot com  2005-08-23 16:05 -------
Sorry, I should have clarified earlier that I'm developing with Java-Gnome head.
I am running it interpreted through Eclipse.

Here's the stack trace it generates:
Exception in thread "main" java.lang.IncompatibleClassChangeError
   at org.gnu.glib.GObject.getGObjectFromHandle(org.gnu.javagnome.Handle)
(Unknown Source)
   at org.gnu.gtk.TextBuffer.getTextBuffer(org.gnu.javagnome.Handle) (Unknown
Source)
   at org.gnu.gtk.TextView.getBuffer() (Unknown Source)
   at TestCase.main(java.lang.String[]) (Unknown Source)
   at gnu.java.lang.MainThread.call_main() (/usr/lib/libgcj.so.6.0.0)
   at gnu.java.lang.MainThread.run() (/usr/lib/libgcj.so.6.0.0)

-- 


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=23216



More information about the Java-prs mailing list