[Bug java/17845] New: can't build GNU Classpath

tromey at gcc dot gnu dot org gcc-bugzilla@gcc.gnu.org
Tue Oct 5 15:42:00 GMT 2004


I can't build GNU Classpath with current cvs gcj.
This may be a regression, though it is also possible
that Classpath changed in a way that gcj can't handle.

The code in question is correct.  It appears that gcj
is picking the wrong 'Certificate':

make[1]: Entering directory `/home/tromey/gnu/classpath/build/lib'
top_builddir=.. /bin/sh ./gen-classlist.sh standard
/home/tromey/gnu/Binarycompat/install/bin/gcj --bootclasspath '' --classpath
../../classpath:../vm/current:.: -C -d . @classes
../../classpath/java/security/cert/X509Certificate.java:143: error: Class
`java.security.cert.X509Certificate' can't subclass interface
`java.security.Certificate'.
   public abstract class X509Certificate extends Certificate implements
X509Extension
                                                 ^
../../classpath/java/security/cert/X509Certificate.java:0: confused by earlier
errors, bailing out

-- 
           Summary: can't build GNU Classpath
           Product: gcc
           Version: 4.0.0
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: java
        AssignedTo: unassigned at gcc dot gnu dot org
        ReportedBy: tromey at gcc dot gnu dot org
                CC: gcc-bugs at gcc dot gnu dot org,java-prs at gcc dot gnu
                    dot org


http://gcc.gnu.org/bugzilla/show_bug.cgi?id=17845



More information about the Java-prs mailing list